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WHY BITCOIN?
Especially if you are not interested in Bitcoin.
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“Bitcoin fixes everything” meme

Bitcoin basics (FI MU), 2024-01-18 https://twitter.com/DominicFrisby/status/1388448025970884609
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Goals for this tutorial

• Bitcoin does not fix everything, but is on a frontline

– No safety net, no chargeback, attacker anonymous => security technique must 

really work, great for battle-testing security ideas, natural “bug bounty program”

• 6 main tech pieces we will cover (also usable outside Bitcoin world)

1. How to backup key(s) (single seed, BIP39, Shamir)

2. How to make always fresh keys (derivation via BIP32, also address privacy)

3. How to protect signing key against malware 

• (multisig, hardware wallet, airgap pc + tx broadcast, mpc sig)

4. How to introduce restricted signing policy (time, limit… lockscript/multisig)

5. How to protect your financial privacy (CoinJoin, Tor)

6. How to use hardware wallet with secure element
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Important questions we will NOT cover: 

Lighting network, mining enviro impact, 

OP_RETURN, price volatility, altcoins tech…

– great topics for chat afterwards!

If interested in more details about 

Bitcoin usage tutorial, visit 

https://crocs.fi.muni.cz/papers/btc

https://crocs.fi.muni.cz/papers/btc
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Bitcoin is built on decades of research ideas.

The main innovation is double-spending 

prevention *without* trusted central party
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Overview

1. Using Bitcoin Core full node (mainnet)

– Start downloading blocks, investigate connected peers, network

2. Using Bitcoin Core full node locally (regtest)

– cli, mining, sending, transactions

3. Group discussions – basic Bitcoin questions

4. Getting and sending some (testnet) bitcoins using SparrowWallet

5. Getting some real sats

Bitcoin basics (FI MU), 2024-01-187
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BASICS
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https://livebitnews.com/wp-content/uploads/2017/09/bitcoin-transaction-life-cycle-high-resolution-1.png

• Wallet

• Address

• Fee

• Transaction

• Signing

• Network nodes

• Block

• Mining

• Proof of Work

• Verification

• Block reward

• Tx confirmation

• And many more…
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Main design goals of the Bitcoin

1. Decentralization

– No central authority or intermediary (=> no single point of failure), possibility of self-custody

– No limitation on network participants (no permission to join is required)

– Applies to executing a transaction, but also development, infrastructure, mining…

2. Transparency

– All transactions recorded on public ledger; validity of every “bitcoin” easy to verify

– Total number of bitcoins in circulation easy to assess (monetary policy, fixed supply)

3. Security based on cryptography (mainly signature, hash functions)

– Ownership of bitcoins proved only cryptographically (no “chargeback” based on human decision)

– Protection of bitcoins reduced to protection of private key(s)

4. Pseudonymity of participants

– bitcoins connected to public keys, not usernames (does not automatically mean anonymity!)
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fullnode

Bitcoin 

P2P network

fullnode

SW-only wallet

With hardware wallet

Blockchain
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Where are my bitcoins?

• Public ledger of all transactions (blockchain)

– Propagated between Bitcoin fullnodes (P2P network)

• “Bitcoin holdings” - sum of values of not-yet-spent transactions control

– Unspent Transaction Output (UTXO) 

• “Bitcoin send” – take “your” UTXO and use it as input to new one

– Specify recipient by script specifying what must be done int future send (lockscript)

– Typical lockscript is “prove that you can sign with private key corresponding to THIS public key”

• “Bitcoin receive” – generate variable part of lockscript (public) and share with 

sender + monitor blockchain for my transaction

• Protection and handling of private keys is paramount

– “Not your keys, not your bitcoin! “
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UTXO set = all currently valid “bitcoins”
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Networks in Bitcoin (Mainnet, Testnet, Regtest)

• Mainnet – main, global production network

• Testnet – testing network (global, some mining happens…)

– Restarted from time to time, contains many different types and versions of TXs

• Regtest – local instance of Bitcoin network

– Used for local testing (integration, regression,debugging)

– Blockchain started from block 0, you are the only miner

– (mined bitcoins unusable on Mainnet)

– You can insert own transactions, decide on mining new blocks, debug…

• Lighting – second layer network of payment channels atop of mainnet

– Practically instant and very low fees independently from mainnet

Bitcoin basics (FI MU), 2024-01-1814
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P2P Bitcoin network map https://bitnodes.io/
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Popular mempool explorer – https://mempool.space

• Can be run on your own fullnode (privacy improvement)

• Testnet version https://mempool.space/testnet

16 Bitcoin basics (FI MU), 2024-01-18
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INTRO
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TASK: USING BITCOIN CORE
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Own work: Using API of full node

• Get Bitcoin full node 24.0.1 (pick .zip or .gz)

– https://github.com/bitcoin/bitcoin/releases

– https://bitcoincore.org/bin/bitcoin-core-24.0.1/

– Download and unpack .zip or .gz

• Download few blocks from real Bitcoin P2P network

– Run bitcoin-qt, Window → Network Traffic (Ctrl+N), Peers (Ctrl+P)

– Observe and document peers to which you connected (number, version, IP)

• Analyze first few blocks from blockchain 

– Look into Bitcoin/blocks/blk00000.dat (e.g., C:/Bitcoin/blocks/blk00000.dat )

– If on Windows, Look for bitcoin folder also in your profile  

• c:\Users\your_name\AppData\Roaming\Bitcoin\blocks\
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Questions

• Why is your full node connecting to other nodes?

• For how long is the Bitcoin network running now?

• What is the content of first block?

• What is the privacy advantage of sending/querying TXs using your 

own full node?

• How can you compute the current supply of bitcoins? 
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TASK: USING BITCOIN-CLI (REGTEST)
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Using API: Bitcoin -regtest
• Optional: regtest network blocks are stored in \Bitcoin\regtest\ (Windows) or ~/.bitcoin/regtest 

(Linux)

– Run "del /S /Q "%APPDATA%\Bitcoin\regtest\" to erase previous one (on LINUX, remove ~/.bitcoin/regtest)

• Run local network (bitcoin daemon)

– bitcoind -regtest

• Open one additional terminal (Win->cmd; Linux->terminal)

• Create new wallet

– bitcoin-cli -regtest createwallet "testwallet"

• Obtain new address for future mined bitcoins (=> miner_address) 

– bitcoin-cli -regtest getnewaddress

• Mine 101 blocks: bitcoin-cli -regtest generatetoaddress 101 miner_address

• Check your balance: bitcoin-cli -regtest getbalance

Bitcoin basics (FI MU), 2024-01-18

This is necessary from 

0.20.0 and higher

Note: Assumed version 24.0.1

Note: on Windows, if you use PowerShell, you 

must prepend .\ before executable

(.\bitcoin-cli instead of bitcoin-cli)
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Using API: Bitcoin -regtest

• Set desired transaction fee BTC/kvB (wallets typically auto computing for you)
– bitcoin-cli -regtest settxfee 0.00002

• Send previously mined bitcoins to new address (getnewaddress→new_address)

– bitcoin-cli -regtest sendtoaddress new_address 10.00

• Display info about transaction: 
– bitcoin-cli -regtest gettransaction txid

• Mine additional to block to include new TX into blockchain…
– https://bitcoin.org/en/developer-examples, https://bitcoin.org/en/developer-reference#bitcoin-core-apis

• Verify total supply: bitcoin-cli -regtest gettxoutsetinfo
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TASK: BITCOIN QUESTIONS
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Questions B (you and ChatGPT)

• Answer the question below with your peers

– How can I pay you 1btc if I have only one UTXO worth of 5btc? 

– What will happen if I will try send double-spending transaction to Bitcoin network?

– Why should you use fresh new address for every receive transaction? 

– What will happen if you create pull request to increasing total number of bitcoins from 21M 

to 100M at https://github.com/bitcoin/bitcoin?

• Ask ChatGPT the question below, then discuss the answer provided critically

– What attacks are possible if I’m using Bitcoin wallet which is not connected to my trusted full 

node?
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TASK: USING SIGNATURE COORDINATOR 
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SINGLE-SIGNATURE WALLET (SW-ONLY)

34 Bitcoin basics (FI MU), 2024-01-18



https://crocs.fi.muni.cz @CRoCS_MUNI

Sparrow wallet (v1.6.6)

• https://www.sparrowwallet.com/download/

• For serious work, always verify binary releases (gpg --verify)

• Well-known and maintained, Java-based, minimum other 

dependencies, focus on medium and advanced users

• Sparrow is “signing coordinator” – private keys can inside or elsewhere

• Basic functionality

– Open-source wallet, non-custodial wallet

– Support for software and hardware wallets, multisignature coordinator 

– Whirlpool CoinJoin client

– Supports also advanced features (PayJoin, Taproot addresses…)
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Starting Sparrow wallet
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• Run your wallet with testnet switch (command line) 

– ./sparrow –n testnet

– Sparrow.exe –n testnet

• Use Public Server option if asked

– Test Connection to verify connectivity 

– Can be changed later File → Settings

• (Bitcoin Core and Private Electrum are more private options)

– You would be connecting to your own fullnode (but you must have one ☺)

• Check that you are online

– (right bottom)

(Examples created for Sparrow 1.6.6)
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• sparrow -n testnet

• File → New wallet

1. New or Imported Software wallet

2. Use 12 Words

3. Generate New

• Write 12 words on paper

• Leave Passphrase empty

– (additional wallet diversification)

Create wallet
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Create wallet
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4. Create Keystore

• Confirm backup

• Reenter words

5. Import Keystore



https://crocs.fi.muni.cz @CRoCS_MUNI

6. Apply

7. Set password or leave empty

– (encryption of local wallet file)

• Local wallet contains seed

– *.mv.db file

– File→Open wallet

Create wallet
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Wallet created (but empty ☺)
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Getting test bitcoins (tBTC)
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• If not running, run your wallet with testnet switch (command line) 

– E.g., ./sparrow –n testnet

– Generate new (testnet) receive address

• Go to https://coinfaucet.eu/en/btc-testnet/

– If doesn’t work use https://testnet-faucet.com/btc-testnet/

– Insert your testnet receive address 

– You may get more every 12 hours (per single IP)

– (but please don’t abuse)

• Check your tx: https://mempool.space/testnet

• Testnet TX explorer: https://blockstream.info/testnet/

– Software visualizing blockchain

https://coinfaucet.eu/en/btc-testnet/
https://testnet-faucet.com/btc-testnet/
https://mempool.space/testnet
https://blockstream.info/testnet/
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Task: send some tBTC to your peer

• Select one of your neighbors as peer (PC1 and PC2)

• Obtain his/her receive address

– Via messenger: PC2 → Receive tab → Copy address → send via Signal → PC1

– Via QR: PC2 → Receive tab ; PC1 → Send → camera icon → scan address QR

• Enter some sats into Amount box

– Observe visualized transaction below (more inputs may be added)

• Try again, but now with manual coin selection

– UTXO tab → select one or more → Send Selected 

46 Bitcoin basics (FI MU), 2024-01-18
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PC1 PC2
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Get mobile wallet

• Get Green wallet by Blockstream on your mobile phone

– https://apps.apple.com/us/app/green-bitcoin-wallet/id1402243590

– https://play.google.com/store/apps/details?id=com.greenaddress.greenbits_android_wallet&

hl=en&gl=us)

– Pick testnet option

• Try send between Green and Sparrow
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Further reading

• Mastering Bitcoin (Andreas M. Antonopoulos and others)

– https://github.com/bitcoinbook/bitcoinbook

• Programming Bitcoin (Jimmy Song)

– https://github.com/jimmysong/programmingbitcoin

• List of interesting resources

– https://blockonomi.com/bitcoin-educational-resources/

– https://learnmeabitcoin.com/, https://learnmeabitcoin.com/technical/

• Bitcoin Twitter, Nostr (https://nostr.com/clients)

– @adam3us @gladstein @ODELL @saylor …

• Podcasts

– https://www.whatbitcoindid.com/ https://stephanlivera.com/
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Getting some real sats (1/100000000 ₿)

• You can get/buy fraction of bitcoin (sats)

• Transaction on mainnet

– potentially costly, ~10mins to execute

– Mainnet is not for buying coffee!

• sats on Lighting – instant and near free

1. Download Wallet of Satoshi

2. Click Receive → QRCode displayed

3. Come to get some

4. Try and learn
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Task: send some lighting sats to your peer

• (Assumption: you already some sats on Lighting wallet)

• Try to send between friends

– Receiver click on ‘Receive’ button

– Sender click on ‘Send’ button, scan QRCode, edit amount, confirm

• Enjoy instant payment

• Inspect Payment Detail (Time, Amount, Total Fees) 
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